Upstream Cloud Provider Outage

Incident Report for Tracsis US

Resolved

Tracsis US cloud dispatching services have been fully restored. Please contact our support group if you continue to experience any problems connecting.
Posted Oct 20, 2025 - 07:31 EDT

Monitoring

We're beginning to see indications that upstream services are recovering and users are able to successfully launch new connections.
Posted Oct 20, 2025 - 06:18 EDT

Identified

Tracsis US cloud dispatching services are currently impacted by an upstream cloud provider that is currently experiencing an outage. Existing connections should not be impacted but users may be unable to launch new connections.
Posted Oct 20, 2025 - 05:50 EDT
This incident affected: Dispatching Services (Dispatching Services).