All firmware upgrades have been successfully applied and verified. This scheduled maintenance is now complete. Please contact our technical services team if you experience any issues.
Posted Oct 21, 2023 - 02:15 EDT
Verifying
All firmware upgrades have been completed. We're now verifying that full system functionality has been restored.
Posted Oct 21, 2023 - 02:07 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 21, 2023 - 01:00 EDT
Scheduled
During this maintenance window, we will be upgrading the firmware of several components of our SaaS Dispatching platform. Throughout the maintenance window, there will be a handful of periods where Citrix connections may get disconnected as services are failed over between the components. We apologize for the short notice and disruption that this maintenance window will cause.
Posted Oct 17, 2023 - 08:40 EDT
This scheduled maintenance affected: Dispatching Services (Dispatching Services).